Skyberate nieuws

End of life van PHP 5.6 en 7.0

End of life van PHP 5.6 en 7.0.

Per 31 december bereik PHP 5.6 zijn end of life datum. Vanaf dan biedt PHP geen support en veiligheidsupdates meer voor versie 5.6 en wordt de ondersteuning voor versie 7.0 afgebouwd. In dit artikel vertellen we je welke gevolgen dit heeft en wat je kunt doen om te zorgen dat je website, webshop of applicatie veilig blijft.

Het ondersteuningsbeleid van PHP

Voor elke PHP-versie wordt vanaf de releasedatum voor gedurende twee jaar ondersteuning gegeven. Tijdens deze periode worden fouten en beveiligingsproblemen verholpen en vrijgegeven in puntsgewijze releases.

Na de actieve ondersteuning voor een periode van twee jaar wordt elke versie nog één jaar lang ondersteund voor kritieke veiligheidsproblemen. Deze security fixes vinden enkel plaats op basis van de behoefte en meldingen van de community.

Zodra de drie jaar van ondersteuning zijn voltooid, bereikt de PHP versie zijn end of life datum en zal deze niet langer meer worden ondersteund. Meer informatie over de support op PHP versies vanuit PHP vind je hier. De afbeelding hieronder laat de tijdlijn zien van de support periode per PHP versie:

 

PHP support

De afbeelding hieronder geeft de betekenis van de kleuren in de afbeelding hierboven weer:

 

PHP support legenda

Verlengde ondersteuning voor PHP 5.6 en PHP 7.0?

Hoewel wij het upgraden naar de laatste versie van PHP toejuichen, snappen wij dat er applicaties zijn die een oudere versie van PHP vereisen. Om onze klanten die nog op oude PHP-versies draaien te ontzorgen, bieden wij in samenwerking met CloudLinux nog geruime tijd security patches voor PHP-versies die officieel End-of-Life zijn. Je kunt dus ook bij ons terecht als je een hostingomgeving nodig hebt met een oudere PHP-versie. Vraag ons naar de mogelijkheden als dit voor jou van toepassing is.

Contact

Wil jij graag meer weten? Neem gerust contact met ons op via 0316-712 000 of info@skyberate.nl

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *